Related Questions:

As a driver, what kind of a phone do I need?

Below are the phones compatible with the Zemcar app. iPads and other tablets are not compatible. You'll need one of these phones to become a ZemDriver.

  • iPhone 6 or newer
  • Samsung 
    • S6 + S6 Edge
    • S7 + S7 Edge
    • S8 + S8 Plus
    • A7
    • A3 2017
  • LG
    • G6
    • K4 2017
    • Nexus